
CSI Solution Demonstrates Use of These Features

n Concrete Moment Frame

n Create Time History Video

n Dynamic Analysis

n Mode Shapes

n New Model From Template

n Link Elements
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n Nonlinear Time History Analysis

Problem Q Solution

1. Click the File menu > New Model command to access the New Model form.

2. Click the drop-down list to set the units to .

3. Click on the 2D Frame button  to access the 2D Frames form. On that form:

n Select Portal in the 2D Frame Type drop-down list.

n Type 3 in the Number of Stories edit box.

n Type 5 in the Number of Bays edit box.

n Uncheck the Restraints check box.

n Click the + (plus) symbol beside the Beams or Columns drop-down list to access the Frame 
Properties form.

¡ Click the Add New Property button to access the Add Frame Section Property form.

¡ In the Frame Section Property Type drop-down list, select Concrete.

¡ Click the Rectangular button to access the Rectangular Section form. In that form:

l Type BEAM in the Section Name edit box.

l Type 36 in the Depth (t3) edit box.

l Type 24 in the Width (t2) edit box.

l Click the + (plus) symbol beside the Materials drop-down list to access the Define 
Materials form. In that form:

n Click the Add New Material Quick button to access the Quick Material 
Definition form. In that form:

¡ Select Concrete in the Material Type drop-down list.

¡ Select f'c 6000 psi in the Specification drop-down list.

¡ Click the OK button to close that form and return to the Define 
Materials form.

n Highlight the 6000Psi material definition and click the Modify/Show Material
button to access the Material Property Data form.

¡ Ensure that the Units are set to  .

¡ Type 0 in the  Weight per Unit Volume edit box.

¡ Accept the default Mass per Unit Volume.

¡ Type 5000 in the Modulus of Elasticity edit box.

¡ Type 0.2 in the Poisson’s Ratio edit box, if it is not already entered.
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¡ Click the OK buttons on the Material Property Data and Define 
Materials forms to close those forms and return to the Rectangular 
Section form.

l Ensure that the 6000Psi material definition is selected in the Materials drop-down 
list.

l Click the OK button on the Rectangular Section form to complete the definition of 
the BEAM section and return to the Frame Properties form.

¡ Click the Add New Property button to access the Add Frame Section Property form.

¡ In the Frame Section Property Type drop-down list, select Concrete.

¡ Click the Rectangular button to access the Rectangular Section form. In that form:

l Type COL in the Section Name edit box.

l Type 24 in the Depth (t3) edit box.

l Type 24 in the Width (t2) edit box.

l Ensure that the 6000Psi material definition is selected in the Materials drop-down 
list.

l Click the OK button on the Rectangular Section form to complete the definition of 
the BEAM section and return to the Frame Properties form.

¡ Click the OK button on the Frame Properties form to return to the 2D Frames form.

n Verify that BEAM is selected in the Beams drop-down list.

n Select  COL  in the Columns drop-down list.

n Click the OK button on the 2D Frames form to close that form and display the template model in 
the program windows.

4. Click the Define menu > Section Properties > Link/Support Properties command to access the
Link/Support Properties form. In that form:

n Click the Add New Property button to access the Link/Support Property Data form. In that form:

¡ Select Rubber Isolator from the Link/Support Type drop-down list.

¡ Type ISO in the Property Name edit box.

¡ Type .001 in the Mass edit box.

¡ Check the U1 Direction check box.

¡ Click the Modify/Show For U1 button to access the Link/Support Directional Properties
form. In that form:

l Type 10000 in the Effective Stiffness edit box.

l Click the OK button to return to the Link/Support Property Data form.

¡ Check the U2 Direction check box.

¡ Check the U2 Nonlinear check box.

¡ Click the Modify/Show For U2 button to access the Link/Support Directional Properties
form. In that form:

l Type 10 in the Effective Stiffness edit box.
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l Type 100 in the Stiffness edit box.

l Type 40 in the Yield Strength edit box.

l Type 0.1 in the Post Yield Stiffness Ratio edit box.

l Accept the other values on the form.

l Click the OK buttons on the Link/Support Directional Properties and Link/Support 
Property Data forms to return to the Link/Support Properties form. In that form:

¡ Click the Add New Property button to access the Link/Support Property Data form. In that 
form:

¡ Select Damper from the Link/Support Type drop-down list.

¡ Type DAMP in the Property Name edit box.

¡ Type 0.001 in the Mass edit box.

¡ Check the U1 Direction check box.

¡ Check the U1 Nonlinear check box.

¡ Click the Modify/Show For U1 button to access the Link Support Direction Properties
form. In that form:

l Type 1000 in the Stiffness edit box.

l Type 30 in the Damping Coefficient edit box.

l Type 0.5 in the Damping Exponent edit box.

l Click the OK buttons on the Link/Support Directional Properties, Link/Support 
Property Data, and Link/Support Properties forms to exit all forms.

5. Click the drop-down list in the status bar to change the units to .

6. Click the “X” in the top right-hand corner of the 3-D View window to close it.

7. Click the Set Display Options button  (or the View menu > Set Display Options command) to display 
the Display Options for Active Window form. In that form:

l Check the Labels box in the Joints area.

l Check the Labels box in the Frames/Cables/Tendons area.

l Click the OK button.

8. Select line (beam) objects 22, 23, 24, 28, 29 and 30.  Press the Delete key on the keyboard to delete 
these objects.

Note:   Select the objects by clicking on each one individually, using the Intersecting Line Select Mode, or using 
the Select menu > Select > Labels command.

9. Click the Draw menu > Quick Draw Frame/Cable Element command to access the Properties of Object
form.  Verify that the Line Object Type is Straight Frame. Ensure that BEAM is selected for the Section.

10. Click on the grid line between joints 17 and 21 to draw a line object (beam) at the base of the isolated 
frame.

11. Click the Set Select Mode button   to exit Draw mode and enter Select mode.

12. Select joints 1, 5, 9 and 13 by clicking on them.
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13. Click the Assign menu > Joint > Restraints command to access the Joint Restraints form. In that form:

n Click the Fixed Base Fast Restraint button  to set all degrees of freedom (U1, U2, U3, R1, 
R2 and R3) as restrained.

n Click the OK button.

14. Click the Draw menu > Draw 1 Joint Link command to access the Properties of Object form.  Select 
ISO from the Property drop-down list.

15. Click on joints 17 and 21 to draw two Link elements.

16. Click the Set Select Mode button  to exit Draw mode and enter Select mode.

17. Click the Draw menu > Draw 2 Joint Link Element command to access the Properties of Object form.  
Select DAMP from the Property drop-down list.

18. Click on joint 9 and then joint 14 to draw a Link element and then hit the Enter key on the keyboard.

19. Click on joint 10 and then joint 15 to draw a Link element and then hit the Enter key on the keyboard.

20. Click on joint 11 and then joint 16 to draw a Link element and then hit the Enter key on the keyboard.

21. Click the Set Select Mode button   to exit Draw mode and enter Select mode.

22. Select all joints at the 2nd, 3rd and Roof levels by “windowing.”

23. Click the Assign menu > Joint Loads > Forces command to access the Joint Forces form. In that form:

n Type -50 in the Force Global Z edit box.

n Click the OK button.

24. Select all joints at the 2nd, 3rd and Roof levels by “windowing.”

25. Click the Assign menu > Joint > Masses command to access the Joint Masses form. In that form:

n Type .25 in the Direction 1 edit box.

n Type .25 in the Direction 3 edit box.

n Click the OK button.

26. Click the Show Undeformed Shape button  to remove the displayed joint mass assignments.

27. Click the Set Display Options button  (or the View menu > Set Display Options command) to access 
the Display Options for Active Window form. In that form:

n Uncheck the Labels box in the Joints area.

n Uncheck the Labels box in the Frames/Cables/Tendons area.

n Click the OK button.

Note:   Before defining time history functions, locate the time history files to be used. For this problem, we are 
using a file named lacc_nor-1.th, but any time history file may be used.  A number of sample files are included 
with SAP2000.

28. Click the Define menu > Functions > Time History command to access the Define Time History 
Functions form. In that form:

n In the Choose Function Type to Add area, click the drop-down list that reads Sine Function and 
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then click Function from File.  

n Click the Add New Function button to access the Time History Function Definition form. In that 
form:

¡ Type LACC0 in the Function Name edit box.

¡ Click the Browse button in the Function File area to access the Pick Function Data File
form. In that form:

l Locate and highlight the time history file to be used (we are using lacc_nor-1.th).

l Click the Open button to return to the Time History Function Definition form.

¡ Type 2 in the Header Lines to Skip edit box.

¡ Type 8 in the Number of Points Per Line edit box.

¡ Select the Values at Equal Intervals option in the Values are area and type .02 in the edit 
box.

n Click the OK buttons on the Time History Function Definition and Define Time History Functions
forms to exit all forms.

29. Click the Define menu > Load Cases command to access the Define Load Cases form. In that form:

n Highlight (select) MODAL in the Load Case Name list.

n Click the Modify/Show Load Case button to access the Load Case Data form. In that form:

¡ Type 30 in the Maximum Number of Modes edit box.

¡ In the Type of Modes area select the Ritz Vectors option.

¡ In the Loads Applied area, verify that Load Pattern shows in the Load Type drop-down list 
and that DEAD shows in the Load Name drop-down list. Click the Add button.

¡ In the Loads Applied area, select Accel from the Load Type drop-down list and UX from 
the Load Name drop-down list. Click the Add button.

¡ In the Loads Applied area, select Link from the Load Type drop-down list.  Click the Add
button

¡ Click the OK button to return to the Define Load Cases form.

n Click the Add New Load Case button to access the Load Case Data form. In that form:

¡ Type GRAV in the Load Case Name edit box.

¡ Select Time History from the Load Case Type drop-down list.

¡ Select the Nonlinear option in the Analysis Type area.

¡ In the Loads Applied area, verify that Load Pattern shows in the Load Type drop-down list 
and that DEAD shows in the Load Name drop-down list.  Select RAMPTH from the 
Function drop-down list.  Click the Add button.

¡ Type 100 in the Number of Output Time Steps edit box.

¡ Type .1 in the Output Time Step Size edit box.

¡ Click the Modify/Show button for Modal Damping in the Other Parameters area to display 
the Modal Damping form. In that form:

l Type .02 in the Constant Damping For All Modes edit box.
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l Click the OK buttons on the Modal Damping and Load Case Data forms to return to 
the Define Load Cases form.

n Click the Add New Load Case button to display the Load Case Data form. In that form:

¡ Type LAC in the Load Case Name edit box.

¡ Select Time History from the Load Case Type drop-down list.

¡ Select the Nonlinear option in the Analysis Type area.

¡ In the Initial Conditions area, select the Continue from State at End of Modal History
option.

¡ In the Loads Applied area, select Accel from the Load Type drop-down list and U1 from the 
Load Name drop-down list.  Select LACC0 from the Function drop-down list, and type 
0.0328 in the Scale Factor edit box. Click the Add button.

¡ Type 1210 in the Number of Output Time Steps edit box.

¡ Type .01 in the Output Time Step Size edit box.

¡ Click the Modify/Show button for Modal Damping in the Other Parameters area to access 
the Modal Damping form. In that form:

l Type .02 in the Constant Damping For All Modes edit box.

l Click the OK buttons on the Modal Damping, Load Case Data and Define Load Cases
forms to exit all forms.

30. Click the Analyze menu > Set Analysis Options command to access the Analysis Options form. In that 
form: 

n Click the Plane Frame XZ Plane button  to set the available degrees of freedom.

n Click the OK button.

31. Click the Run Analysis button  to access the Set Load Cases to Run form. In that form:

n Verify that all load cases are set to Run in the Action list.

n Click the Run Now button to run the analysis.

32. When the analysis is complete, check the messages in the SAP Analysis Monitor window and then click 
the OK button to close the window.

33. Click the Start Animation button  on the status bar at the bottom of the screen to 
animate the first mode shape.

34. Click the Right Arrow button  on the status bar at the bottom of the screen to view the next mode 
shape.

35. Continue clicking the Right Arrow button  to step through all of the mode shapes.

36. Click the Show Undeformed Shape button  to remove the displayed mode shape.

37. Click the File menu > Create Video> Create Multi-step Animation Video command to access the Video 
File form. In that form, select the name and location for the video file (*.avi) and click the Save button.  
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The Multi-step Video File Creation form is displayed. In that form:

n Select LAC from the Case Name drop-down list.

n Type 50 in the Magnification Factor edit box.

n Verify that 640 by 480 is entered in the Frame Size (Pixels) edit boxes. 

n Click the OK button and the Video Compression form will display. In that form, note that the Full 
Frames (Uncompressed) option is selected; as the name suggests, the file will uncompressed.

n Click the OK button on the Video Compression form to create the *.avi file.

Note:   After the *.avi file has been created, it can be played on any multimedia player that supports *.avi files.  

Note:   The purpose of this example is to display the capabilities of SAP2000.  The structural properties of each 
frame have not been optimized in this example.  Therefore, great care should be taken in drawing any 
conclusions about the relative performance of different structural systems based on this example.
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